Mac 安装php7.2+和composer

Mac 安装php7.2+和composer

安装php7.2+

操作步骤

  1. 安装HomeBrew
/bin/zsh -c "$(curl -fsSL https://gitee.com/cunkai/HomebrewCN/raw/master/Homebrew.sh)"
  1. 使用Brew安装Php
brew install php@7.2
// Error: php@7.2 has been disabled because it is deprecated upstream!
// 提示官方已不再维护
  1. 使用第三方仓库
// 将第三方仓库加入brew
brew tap shivammathur/php
// 安装PHP
brew install shivammathur/php/php@7.2
  1. 提示写入环境变量

Mac 安装php7.2+和composer

  • 前往文件夹 ~/,修改 .bash_profile 文件
export LDFLAGS="-L/usr/local/opt/php@7.2/lib"
export CPPFLAGS="-I/usr/local/opt/php@7.2/include"
  • 前往文件夹 ~/,修改 . zshrc 文件
source ~/.bash_profile
  1. 链接 php 版本
brew link --overwrite php@7.2
  • 重启终端或执行 brew services restart php
  • 查看php版本 php -V
  1. 其他配置

修改文件 /usr/local/etc/php/7.2/php-fpm.conf,去掉第17行、24行前面分号

Mac 安装php7.2+和composer

其他说明

  • 应确保 ssh -T git@github.com 链接github命令正常

安装composer

  1. 下载composer(eg. 2.4.4):Composer
  2. 移动 composer.phar 文件到 /usr/local/bin 下:打开终端 执行命令 mv composer.phar /usr/local/bin/composer
  3. 赋予composer执行权限: chmod +x /usr/local/bin/composer
  4. 测试 composer

Mac 安装php7.2+和composer

### 安装多个版本php –2023.01.14 更新
#### 操作步骤
1. 查看仓库 `brew search php`

![](https://img2023.cnblogs.com/blog/529800/202301/529800-20230114162633890-18915096.png)

2. 安装php5.6   

`brew install shivammathur/php/php@5.6`

3. 添加PHP环境变量

```
# 终端
vim ~/.bash_profile  
 
# 新增
export PATH="/opt/homebrew/opt/php@5.6/bin:$PATH"
export PATH="/opt/homebrew/opt/php@5.6/sbin:$PATH"  
 
# 终端 刷新 ~/.bash_profile
source ~/.bash_profile
```

4. 安装PHP版本切换工具 brew-php-swither 
```
brew install brew-php-switcher
```

5. 切换和使用不同版本php

```
# 切换版本
brew-php-switcher 5.6
brew-php-switcher 7.2

php -v

# 其他命令
brew services start php@5.6 # 启动 php5.6
brew services stop php@5.6 #关闭 php5.6
```

                       

点击阅读全文

上一篇 2023年 6月 12日 am10:16
下一篇 2023年 6月 12日 am10:18