最新mac切换php版本(升版本和降版本)亲测有效

最新mac切换php版本(升版本和降版本)亲测有效

由于公司新业务的项目与老项目PHP环境版本不一致,导致一部分老项目刚接手过来环境运行不起来,涉及到PHP版本切换,包括升版本和降版本问题的解决

查看电脑已经运行的PHP版本

php -v

最新mac切换php版本(升版本和降版本)亲测有效

 可以看到mac下brew安装的服务程序

brew services list

最新mac切换php版本(升版本和降版本)亲测有效
刚接手的项目却要7.0版本的PHP,方法大概有五种方法(莫执行以下命令,仅罗列)

一 brew unlink php@xxx

二 brew uninstall  php@xxx

三 brew-php-switcher  php@xxx

四 brew services stop php@xxx

五 sudo vim  ~/.bash_profilexxx

在文件后面添加:

export PATH=/usr/local/Cellar/php@xxx/7.2.23/bin:/usr/local/Cellar/php@xxxx/7.2.23/sbin:${PATH}
source ~/.bash_profilexxxx

先说我用的最有效的方法:

最新mac切换php版本(升版本和降版本)亲测有效

由于官方在维护的的只有8.0以上 版本,7.0版本已经不在维护,所以直接从官方拉取7.0版本的都会失败,mac上使用brew安装旧版php,执行brew install php@7.xxx报错Error: php@7.xxxx

所以要引入就旧版本库 , brew加入第三方仓库

brew tap shivammathur/php

最新mac切换php版本(升版本和降版本)亲测有效

安装php相应的版本,例如7.4

brew install shivammathur/php/php@7.4

最新mac切换php版本(升版本和降版本)亲测有效

建立链接并强制切换到7.4版本

brew link --overwrite --force shivammathur/php/php@7.4

最新mac切换php版本(升版本和降版本)亲测有效
 

PHP -v查看最新PHP版本 

最新mac切换php版本(升版本和降版本)亲测有效

切换到相应版本下,运行PHP-fpm,启动正常

最新mac切换php版本(升版本和降版本)亲测有效
 

这样大功告成

                       

点击阅读全文

上一篇 2023年 6月 10日 am10:26
下一篇 2023年 6月 10日 am10:27