MacOS 系统如何把PHP版本升级到 7.4或者更高的版本呢,今天教程来啦

MacOS 系统如何把PHP版本升级到 7.4或者更高的版本呢,今天教程来啦

⾸先保证 homebrew 为最新版本,先升级 homebrew 到最新

brew update

然后升级 PHP 版本

brew upgrade php

使⽤php -v检查 php 版本

php -v

如果没有升级成功或者其他报错,可以使⽤

brew install php@7.4

直接安装 php 7.4 版本。

修改服务器对应的 PHP 版本

修改nginx 或者apache的配置⽂件,以 apache为例:

sudo vim /etc/apache2/httpd.conf

找到 LoadModule php7_module 这⾏,修改为:

LoadModule php7_module /usr/local/Cellar/php@7.4/7.4.16/lib/httpd/modules/libphp7.so

重启 nginx 或者 apache 服务器

sudo ngingx -s reload
sudo apachectl restart

确保⽹站服务使⽤的也是 php 7.4 版本,在服务器的根⽬录index.php中

<?php
phpinfo();
?>

使⽤ PECL 安装对应扩展

pecl install imagick
pecl install redis

使⽤ pecl list 查看已经通过 pecl 安装的扩展

$ pecl list
Installed packages, channel pecl.php.net:
=========================================
Package Version State
imagick 3.4.4 stable
redis 5.1.1 stable

如果之前使⽤ pecl 安装过其他版本PHP的扩展,可以使⽤ pecl uninstall (ext_name) 卸载后重新安装。

曾尝试过修改 php.ini 的扩展⽬录为之前的,但是报错

; Directory in which the loadable extensions (modules) reside.
; http://php.net/extension-dir
extension_dir = "/usr/local/lib/php/pecl/20190902"
; On windows:
;extension_dir = "ext"

索性之前使⽤ pecl install 重新安装⼀遍。

安装成功后使⽤ php -m | grep imagick 查看⼀下是否存在。

最后
如果你觉得此文对你有一丁点帮助,点个赞。或者可以加入我的开发交流群:1025263163相互学习,我们会有专业的技术答疑解惑

如果你觉得这篇文章对你有点用的话,麻烦请给我们的开源项目点点star:http://github.crmeb.net/u/defu不胜感激 !

免费源码获取地址:https://www.crmeb.com

PHP学习手册:https://doc.crmeb.com
技术交流论坛:https://q.crmeb.com

                       

点击阅读全文

上一篇 2023年 6月 9日 pm9:01
下一篇 2023年 6月 9日 pm9:01